CONTA SE EXCEL spiegata in dettaglio (con esempi reali e file di esercitazione da scaricare)

Il conta se Excel è un’importante funzione di Excel che ti permette di contare le celle che soddisfano una condizione che hai impostato (è simile al somma se Excel, con la differenza che in questo caso la funzione conta, invece di sommare).

La funzione conta se di Excel ti permette di contare quante volte si ripete una data parola all’interno di un elenco, quanti prodotti superano un determinato prezzo (per esempio all’interno di un listino prezzi) oppure quanti giorni superano una certa data e così via…

Se adesso hai un po’ di confusione è normale ma no ti preoccupare! Continua a leggere l’articolo e vedrai che tra qualche minuto sarà tutto chiaro!

Iniziamo dalle basi: la sintassi

CONTA SE EXCEL: la sintassi

La sintassi del conta se è la seguente:

=CONTA.SE(intervallo;criteri)

Intervallo: è l’insieme di celle in cui vuoi applicare il criterio.

Criterio: è il criterio con cui selezioni le celle da contare.

Vediamo ora qualche esempio:

CONTA SE EXCEL : Esempi

Prendiamo come esempio il seguente set di dati:

conta se excel dataset

Questa tabella rappresenta una serie di prodotti alimentari di 4 categorie diverse: Frutta, Verdura, Cereali e nessuna categoria (cella vuota).

Nella colonne B, C e D ci sono il prodotto specifico, il prezzo e la data di scadenza rispettivamente.

Iniziamo ad applicare alla tabella alcuni esempi della formula conta.se.

CONTA SE EXCEL CON CRITERI TESTUALI

=CONTA.SE(A1:A18;”FRUTTA”)

Con questa formula contiamo il numero di prodotti che appartengono alla categoria “FRUTTA” nell’intervallo A1:A18. Il risultato è 6.

=CONTA.SE(A1:A18;E2)

Stesso risultato di prima. Al posto di scrivere il testo all’interno della formula, abbiamo indicato la cella con il testo da contare.

=CONTA.SE(A1:A18;”<>FRUTTA”)

In questo caso contiamo tutti i prodotti che NON rientrano nella categoria FRUTTA. Il risultato è 12.

Se non conosci questo simbolo <> è il simbolo di diverso in Excel.

=CONTA.SE(A1:A18;”<>”&E2)

Stesso risultato di prima. In questo caso abbiamo utilizzato un simbolo particolare (&) che serve per concatenare delle celle. La sintassi “<>”&E2 equivale a “<>FRUTTA”

Utilizzo del CONTA SE EXCEL con caratteri JOLLY

Ora vediamo l’utilizzo di alcuni caratteri Jolly: l’asterisco (*) e il punto di domanda (?).

Carattere Jolly: asterisco *

L’asterisco (*) indica ad Excel qualsiasi testo di qualsiasi lunghezza, compreso lo zero.

Per esempio, la seguente formula:

=CONTA.SE(A2:A18; “*A”)

conta il numero di prodotti che appartengo alle categorie che terminano con la lettera A (in questo caso FRUTTA e VERDURA). Il risultato è 11.

L’utilizzo dell’asterisco è utile quando dobbiamo contare le celle che contengono parte di un testo specifico.

=CONTA.SE(B2:B18; “*an*”)

In questo caso, contiamo i prodotti che hanno le lettere “an” all’interno del testo (quindi: Ananas, Arance, Banane, Melanzane). Il risultato è 4.

Carattere Jolly: punto di domanda ?

Il carattere jolly ? indica un singolo carattere. Per esempio la seguente formula conta le celle che contengono testo di 4 caratteri (Pere, Mele e Orzo). Il risultato è 3.

=CONTA.SE(B2:B18;”????”)

Oppure possiamo contare le celle che contengono testo di 4 caratteri e il quarto è la lettera e (quindi Pere e Mele); il risultato è 2:

=CONTA.SE(B2:B18;”???e”)

CONTA SE CON CRITERI NUMERICI

E’ possibile anche utilizzare un criterio numerico.

Per esempio questa funzione

=CONTA.SE(C2:C18;”>10″)

conta i prodotti che hanno un prezzo maggiore di 10. Il risultato è 5.

Mentre questa formula

=CONTA.SE(C2:C18;”>=11″)

conta i prodotti che hanno un prezzo maggiore o uguale a 11. Il risultato è 5.

CONTARE LE CELLE PIENE O VUOTE

E’ possibile contare le celle piene (contenente testo o numeri) con la seguente formula:

=CONTA.SE(A2:A18;”<>”)

Il risultato è 15.

Mentre se vuoi contare le celle che contengono SOLO testo, la formula è:

=CONTA.SE(A2:A18;”*”)

Il risultato è 15.

Per contare le celle vuote, la formula è:

=CONTA.SE(A2:A18;””)

CONTA SE applicato alle DATE

E’ possibile applicare il conta se alla date. Per esempio è possibile calcolare i prodotti che scadono entro il 31/12/2017. La sintassi è:

=CONTA.SE(D2:D18;”<31/12/2017″)

Il risultato è 15.

Oppure è possibile contare il numero di prodotti che sono scaduti. In questo caso si utilizza la formula OGGI() con il concatena &:

=CONTA.SE(D2:D18; “<“&OGGI())

CONTARE le celle all’interno di un intervallo

Per esempio, posso contare i prodotti che hanno un valore compreso tra 5 e 10 (non compresi):

=CONTA.SE(C2:C18;”<10″)-CONTA.SE(C2:C18;”<5″). Il risultato è 6.

Errori comuni

Attenzione a inserire sempre i doppi apici, anche se si tratta di un valore numerico.

I criteri testuali non fanno distinzione tra le lettere maiuscole o minuscole.

Se hai problemi nell’utilizzo di questa formula, nessun problema: contattami e vediamo di implementarla correttamente all’interno del tuo foglio di calcolo.

Esercizi da fare e il foglio con gli esempi

Per imparare Excel occorre fare tanta pratica.

Come prima cosa puoi scaricare il foglio con gli esempi che abbiamo visto in questo articolo.

Così che se c’è qualcosa che non ti è chiaro, puoi studiare la formula direttamente all’interno del foglio di calcolo.

All’interno del foglio troverai anche alcuni esercizi da fare per poterti esercitare (con le relative soluzioni).

Una volta aperto il file Excel, in basso a sinistra troverai tre linguette (che in Excel si chiamano fogli).

Nel primo foglio ci sono gli esempi, nel foglio “ESERCIZI” ci sono gli esercizi da fare e nel foglio “SOLUZIONE” c’è la soluzione agli esercizi. Per passare da un foglio all’altro ti basta cliccare sulla linguetta.

Per scaricare il foglio Excel con gli esempi e gli esercizi, non devi far altro che inserire la tua migliore email e cliccare sul pulsante.

Ti chiedo la cortesia di iscriverti alla newsletter. L’iscrizione è gratuita, non ti basta far altro che inserire l’email.

PS Vuoi imparare Excel? Acquista ora il nostro corso di Excel online!

Lascia un commento

Il tuo indirizzo email non sarà pubblicato.

Questo sito usa Akismet per ridurre lo spam. Scopri come i tuoi dati vengono elaborati.