Funzione SE nidificata di Excel (con esempi)

Vediamo ora il caso della funzione se nidificata (prima di vedere questa funzione, devi saper utilizzare la funzione se di Excel)

funzione se nidificata Excel

Le funzioni annidate non sono altro che funzioni che hanno ulteriori funzioni come altri argomenti.

In quest’ultimo scenario, quindi, gli argomenti “se vero” e “se falso” possono essere altre funzioni.

Al fine di semplificarci la vita, vediamo subito con un esempio concreto dell funzione se nidificata

Funzione SE nidificata: esempio

Consideriamo i reparti di una squadra di calcio, vale a dire difensori, centrocampisti ed attaccanti.

Ci interessa sapere il numero di gol realizzati nell’ultimo campionato.

Immagine di esempio della funzione se nidificata

I difensori ne hanno siglati 5, i centrocampisti 18, i trequartisti 24 e gli attaccanti 45.

In basso, vi è una piccola tabella che ci indica un’informazione essenziale ai fini dell’esempio.

Se il numero dei gol totali dei reparti sono superiori a 30 (> 30), allora l’allenatore trarrà conclusioni positive con tanto di “OK” come feedback.

Se invece, la somma si dimostra inferiore a 30 (<30), allora i reparti avranno ancora molto da lavorare. Feedback “NO“.

Obiettivo di questo esempio è quello di creare una formula, basata inevitabilmente sulla Funzione SE di Excel.

Dovendo agire sulla somma, il punto di partenza è quello di calcolarla. Posizionandoci nella cella B6, procediamo al calcolo, selezionando il range di riferimento. =Somma(B2:B5).

Dando il tasto di invio, il risultato sarà pari a 92 reti in campionato. Questo lo score della squadra.

Posizioniamoci adesso nella cella C7 e procediamo all’inserimento della Formula SE.

Bisognerà lavorare con la disequazione.

Pertanto, il test sarà sostanzialmente questo: se è vero che il risultato sarà maggiore di 30, in quanto numero determinante, l’obiettivo consisterà nel visualizzare la scritta “OK“.

In caso contrario, verrà mostrata la dicitura “NO“. Ricordiamo che entrambe le scritte vanno necessariamente inserite tra virgolette. Il “Se Vero” verrà separato dal “Se Falso” dal classico punto e virgola (;). Ne consegue che:

=SE(B6>30;”OK”;”NO”)

La formula funziona correttamente, dato che viene visualizzato il risultato “OK“. B6 è 92 che è appunto maggiore di 30.

Nulla di nuovo rispetto a quanto indicato prima, dato che è stata presentata la Funzione SE.

Sarebbe stato possibile, però accelerare le operazioni, saltando un passaggio, ed è qui che la funzione se nidificata ci viene in aiuto.

Copiamo ed incolliamo la tabella sullo stesso foglio di Excel. La formula SE, stavolta, verrà scritta in maniera differente.

Non verrà fatta, infatti, la sommatoria delle reti della squadra nel campionato. La somma verrà effettuata direttamente all’interno della formula SE.

Nella cella J7, verrà scritta una comune formula SE. Il test consisterà nel verificare se la somma dei gol dei reparti è maggiore di 30 (feedback “OK”) o inferiore a 30 (feedback “NO“).

C’è da dire che la somma delle reti dei reparti, non l’abbiamo. Occorre calcolarla. Come si fa? Il test della formula SE diventa una nuova formula: nella fattispecie, la somma.

Pertanto, il comportamento non si discosta da una classica somma.

=SE(Somma(H2:H5). Il test, però, risulta ancora incompleto, perché urge inserire ancora la disequazione.

Come deve essere la somma? Maggiore di 30. “Se Vero“, il test deve restituire il feedback “OK“. In caso contrario, se inferiore a 30, il feedback sarà “NO“.

Perciò:

=SE(SOMMA(H2:H5)>30;”OK”;”NO”)

Excel restituisce nuovamente “OK” come risultato, perché la somma dei gol della squadra è superiore a 30.

Vediamo nei dettagli la differenza tra la prima parte e la seconda parte.

All’inizio, sono state utilizzate due formule distinte e separate, al fine di ottenere lo stesso risultato. Per l’argomento “Test” è stata impiegata direttamente la cella contenente la sommatoria delle reti. Quindi, “B6“. Vale a dire 92 reti.

Se vero, “OK“. Se falso, “NO“.

Nel secondo caso, è stato fatto tutto in un unico passaggio. La prima formula che è la principale è ovviamente la formula SE.

Dopodiché, il primo argomento della formula

=SE(SOMMA(H2:H5)>30;”OK”;”NO”) va fino a “30”.

La differenza sta nel fatto che nel primo esempio è stato usato B6 come parametro già fatto e finito, mentre nel secondo caso all’interno della formula SE è stata riportata anche quella della somma all’interno dell’argomento.

Si è creato di fatto una funzione nidificata, dove appunto uno degli argomenti della formula SE è la funzione “SOMMA“.

Questo è un esempio veloce per spiegare la logica di funzionamento della funzione se annidate.

Con i file di grandi dimensioni, saperle sfruttare è sinonimo di risparmio di tempo.

Lascia un commento

Il tuo indirizzo email non sarà pubblicato.

Questo sito usa Akismet per ridurre lo spam. Scopri come i tuoi dati vengono elaborati.